Frequently Asked Questions

Is the first generation FireStick supported?
Last Updated about a month ago

MonsterVPN (and other VPN providers) appear to have issues running on the first generation Firestick. Amazon have not given an official response regarding why some work and some do not.

There are no issues with MonsterVPN running on the 2nd generation Firestick or any other Fire TV devices.

Please Wait!

Please wait... it will take a second!